EN
AR
Products

Get exactly the support you need
Looking for specific solutions for your product?

I cannot download/install the Philips Treatment app.

Please check if your smart device meets the minimum requirements for this app. The app is supported by the following devices: iPhone 4S, 5, 5C, 5S or newer. iPod Touch 5th generation, iPad mini retina, iPad mini non-retina, iPad 3 retina, iPad 4 retina, iPad air. Newer devices than these are also supported. The device has to run on iOS7 or higher. The Android App will run on devices with Android 4.4 (Kitkat) or higher. Also check if you have a stable internet connection on your smart device. Loss of connection will hamper the downloading of the app.

Our site can best be viewed with the latest version of Microsoft Edge, Google Chrome or Firefox.